Back to overview
Downtime

Mobile Network Degradation

Jun 5, 2026 at 10:33am UTC
Affected services
Mobile Network A

Updated
Jun 5, 2026 at 3:52pm UTC

The network service provider's team is actively working and coordinating with their upstream service provider on an alternate workaround to restore service. The issue has been confirmed to be with the upstream service provider, and there is currently no estimated time for resolution (ETR). We will continue to provide updates as more information becomes available.

Updated
Jun 5, 2026 at 2:47pm UTC

The network service provider's engineers continue to work with their upstream service providers to investigate this case and have identified the issue to be with their upstream service provider. There is currently no estimated time for resolution (ETR). We will continue to provide updates as more information becomes available.

Updated
Jun 5, 2026 at 1:53pm UTC

Our network service provider's engineers have engaged the relevant upstream service providers and continue to troubleshoot the issue. The case has been escalated and there is currently no estimated time for resolution (ETR). We will continue to provide updates as more information becomes available.

Updated
Jun 5, 2026 at 12:34pm UTC

The network service provider's engineers continue to troubleshoot the issue. Additional escalation measures have been taken by them. No ETR is available at this time.

Updated
Jun 5, 2026 at 10:53am UTC

The network service provider has confirmed an issue on their side and is now investigating.

Created
Jun 5, 2026 at 10:33am UTC

Our monitoring systems have identified a decrease in inbound traffic from one of our mobile network providers, which is expected to cause delays in GPS updates for a subset of resources within the portal. We have initiated investigations to identify the underlying issue.