Back to overview
Degraded
Mobile Network Degradation
May 20, 2026 at 9:29pm UTC
Affected services
Mobile Network A
Resolved
May 20, 2026 at 9:59pm UTC
We are now observing a return to normal inbound data levels. We will continue to monitor and provide further updates if necessary. Thank you for your patience and understanding.
Affected services
Created
May 20, 2026 at 9:29pm UTC
Our monitoring systems have identified a decrease in inbound traffic from one of our mobile network providers, which is expected to cause delays in GPS updates for a subset of resources within the portal. We have initiated investigations to identify the underlying issue.
Affected services