Back to overview
Degraded

Mobile Data Degradation

Dec 11 at 04:15pm GMT
Affected services
Mobile Data

Resolved
Dec 11 at 06:29pm GMT

We have applied a fix and returned service to normal levels.

We will continue to monitor this into the evening to ensure there is no further disruption.

Updated
Dec 11 at 05:12pm GMT

We are continuing to investigate an issue affecting a subset of mobile data devices.

We appreciate your patience as we work to resolve the issue and restore normal functionality.

Created
Dec 11 at 04:15pm GMT

We are currently investigating an issue affecting a subset of mobile data devices.

We appreciate your patience as we work to resolve the issue and restore normal functionality.