Back to overview
Degraded

Isotrak ELD Service Disruption

Jan 17 at 11:57am GMT
Affected services
ELD Portal

Resolved
Jan 17 at 12:28pm GMT

Our partner has resolved the issue and the ELD portal is now available for login.

Created
Jan 17 at 11:57am GMT

We have been made aware of an issue with logging into the ELD portal. Our partner is currently investigating the cause of the disruption and troubleshooting to restore services.

Impact: Ability to login to the ELD portal or the mobile application for some users.

Guidance: Please inform your drivers that are already logged in to stay logged in. To avoid the possibility of data loss and/or access to the service for these drivers, staying logged in will allow the application to continue to track and store their information on the application.