Back to overview
Degraded

Isotrak ELD - API Service Disruption

Dec 13 at 09:33am GMT
Affected services
ELD API

Resolved
Dec 13 at 10:32am GMT

Our partner has resolved the issue, and the portal and API services are now available.

Created
Dec 13 at 09:33am GMT

We are currently experiencing an issue with the availability of the ELD API services. This matter has been escalated to our partners for further investigation. We will continue to monitor the situation closely.