Back to overview
Degraded

Isotrak ELD - Portal and API Service Disruption

Jan 05 at 08:30am GMT
Affected services
ELD Portal
ELD API

Resolved
Jan 05 at 10:14am GMT

Our partner has resolved the issue, and the portal and API services are now available.

Created
Jan 05 at 08:30am GMT

We are currently experiencing an issue with the availability of the ELD API services. This matter has been escalated to our partners for further investigation. We will continue to monitor the situation closely.